ruff start idol and bogs down full throttle

denny4denny

Member
Messages
30
Reaction score
14
Location
union mo.
150cc gy6 did a rebuild with new carb it started and ran great then after a few short hrs it is hard to start idol ruff tries to die and open throttle going down hill it b ogs down like its out of gas. i have replaced carb.twice .replaced intake manifold added a gasket and coated in permatex. and spark plugs. and a added a vacum fuel pump .nothing has helped
 

denny4denny

Member
Messages
30
Reaction score
14
Location
union mo.
What about the fuel filter in the tank or the regular fuel filter? What does the belt and clutches look like?
filters been changer as well as fuel lines and vacuum lines .now you got me on the clutch and belt .what would they have to do with hard starting ect.
 

Rat

Well-known member
Messages
1,119
Reaction score
672
Location
SW Virginia
New carb, New lines, New filters...

Did you bother to tune the carb, or did you just assume it was okay to bolt on and go?
Reading this all I see is a carb that requires proper jetting and/or proper adjustments.
 

LaithSaah

New member
Messages
15
Reaction score
12
Had a really similar problem with a predator 212, running very lean. Dont know about your case though. Take a page out of this and try playing with jet sizing:
New carb, New lines, New filters...

Did you bother to tune the carb, or did you just assume it was okay to bolt on and go?
Reading this all I see is a carb that requires proper jetting and/or proper adjustments.
 

denny4denny

Member
Messages
30
Reaction score
14
Location
union mo.
Are they dragging, putting a load on the engine.
it takes off great if your in gravel it will throw gravel but it going down a steep hill as you let off the throttle it will kick back like it out of gas going down at least a couple times then when first stop it acts like it wants die i give it a little pump on the gas it will then idol but ruff
 

denny4denny

Member
Messages
30
Reaction score
14
Location
union mo.
i thought it was sucking air but i cant find where. i sprayed starting fluid around fittings but i didnt notice anything going on
 

denny4denny

Member
Messages
30
Reaction score
14
Location
union mo.
Had a really similar problem with a predator 212, running very lean. Dont know about your case though. Take a page out of this and try playing with jet sizing:
i can pull the plug and its dark in a short time so if anything it running rich.but if i turn it down say 1/2 turn then its much worse.it takes off slow and very slow to get its headway up. i got run the idol way up to keep from dieing
 

BrownStainRacing

Well-known member
Messages
1,344
Reaction score
1,330
i can pull the plug and its dark in a short time so if anything it running rich.but if i turn it down say 1/2 turn then its much worse.it takes off slow and very slow to get its headway up. i got run the idol way up to keep from dieing
Unplug the wires going to the enrichner on the carb and do at least a 10 min test ride. Stay close to home, incase it fouls a plug, or carry another plug and tools to change it.

If it runs the exact same, the enrichner is not closing and loading up the carb (rich) . Usually it lost power in a wire coming from the stator.

If it runs worse, the enrichner is working and you can rule that out.

They are finicky. I always test them and make sure they work before installing. It's 1 of those parts that I jus don't trust, new or old.

To test, I wire them straight to a 12v battery and see how long it takes to completely close. Some close faster then others.
 
Top