212 choke problem

zzuspann

New member
Messages
9
Reaction score
0
I’ve had my 212 running good for about 6 weeks, and one day when I went to start it up, it would only run when choked - when I would switch it off, the engine would die out. I replaced the carb and checked for any leakage but nothing seemed to work. One thing I should also mention is that the engine seems to start easier when the airbox is loosened a bit, so it may have something to do with that. Any help is appreciated.
 

zzuspann

New member
Messages
9
Reaction score
0
I actually already replaced it, when searching around I thought that was the problem as well, but I suppose not
 

zzuspann

New member
Messages
9
Reaction score
0
I’ve toyed around with the idle screw, but that doesn’t seem to be the problem. But how would I change the carb mixture ratio? I’ve also looked through some other threads and seen some things regarding the spark plug possibly being deficient - should I look more into that?
 

Kent

Member
Messages
113
Reaction score
2
Location
Willits, California (Northern California)
Doesn't sound like a problem with the plug if it runs while choked. There should be a mixture screw on the carb. Some carbs have a cap or something to prevent us from adjusting the mixture (not sure why). You should be able to defeat that and adjust your carb. If you post some pixs of the carb the members here will tell you how to adjust it. There is a lot of info on the web that might be helpful as well.

I have read somewhere that some of the China carbs ship with some **** inside them that causes the carb to be idled for about a half hour before use. Otherwise problems like you are having may happen. I have never heard of Predator engines having that problem. I have only dealt with one new 212 and it ran great out of the box.

Don't be discouraged if you just happened to get one that has some part that's bad from the factory. That's not your fault. Stick with it and the members of this forum will help you. They have helped me many times and I am an newbie. If you have trouble figuring out the carb send some pixs from several angles of the carb. To me it sounds like that's where your problem is.
 

zzuspann

New member
Messages
9
Reaction score
0
Thanks, I’ll look into adjusting the ratio, and post pics if I need help. I also should’ve mentioned this earlier but yes, a while ago, I could get the engine running on choke, and it would cut out when I’d flip it off, but after I tried again today I couldn’t even get it started all - maybe a combination of a couple problems?
Something else I should mention is I’ve experimented taking off the airbox cap and filter a couple times when trying to start it up, and it seems like when I yank to start, air is being pushed up out of the box - I’m not sure if that would change the diagnosis but I thought I’d add any more detail I can
 

zzuspann

New member
Messages
9
Reaction score
0
Thanks, I’ll look into adjusting the ratio, and post pics if I need help. I also should’ve mentioned this earlier but yes, a while ago, I could get the engine running on choke, and it would cut out when I’d flip it off, but after I tried again today I couldn’t even get it started all - maybe a combination of a couple problems?
Something else I should mention is I’ve experimented taking off the airbox cap and filter a couple times when trying to start it up, and it seems like when I yank to start, air is being pushed up out of the box - I’m not sure if that would change the diagnosis but I thought I’d add any more detail I can
I’m not sure if you’ll see this again, but thanks for your help anyway - the problem ended up having to do with the airbox only being secured by one nut, which created a leak. When my brake nut broke, I ended up taking one off the airbox that was the same size, and used it for the brake. I should’ve located this problem earlier, but was thrown for a loop by the engine being able to start easier when the box was loosened.
 

mckutzy

Active member
Messages
8,312
Reaction score
9
Location
bc, canada
They have a none adjustable car present on them due to environmental laws.... Its factory adjusted, then they break off the screw head, seal it with glue.
In Cali they have usually have a separate version( Predator and others I can imagine) only sold to that state, As I recall.....
 
Top