Go Back   DIY Go Kart Forum > Other Stuff > Off Topic Forum

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 08-22-2019, 06:23 PM
supermanotorious's Avatar
supermanotorious supermanotorious is offline
Winchmaster 5000
 
Join Date: Jun 2009
Location: New River, AZ
Posts: 2,090
Thanks: 212
Thanked 440 Times in 327 Posts
Default man I'm a knucklehead sometimes

Dang ol boat wouldn't start last weekend, sounded like the starter was grinding gears.... sound familiar? Sound like THIS old thread?!



well I didn't remember it! I had my battery on the charger and confirmed it was "fully charged" but didn't think to use my load tester on the battery, still no start! so I pulled the starter!! that was a PITA!



I confirmed it was working and not in fact stripped, so yeah, I bought a new battery (sheesh)
__________________
www.phoenixwinch.com
www.facebook.com/wakeskatewinches www.youtube.com/user/phoenixwinch
Reply With Quote
The Following 2 Users Say Thank You to supermanotorious For This Useful Post:
2SlickNick (08-22-2019), Kartorbust (08-22-2019)
  #2  
Old 08-26-2019, 05:06 AM
landuse's Avatar
landuse landuse is offline
Moderator
 
Join Date: Nov 2010
Location: Pietermaritzburg, South Africa
Posts: 17,357
Thanks: 2,124
Thanked 3,462 Times in 2,823 Posts
Default

It is always the obvious things....and we seem to check them last!! I'm glad you figured it out though
Reply With Quote
The Following User Says Thank You to landuse For This Useful Post:
supermanotorious (08-27-2019)
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 07:54 PM.