Go Back   DIY Go Kart Forum > Building Plans And Advice > Go Kart Discussion

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 02-02-2020, 11:56 AM
buildinthrillz buildinthrillz is offline
Junior Member
 
Join Date: Jan 2020
Location: Bartow fl
Posts: 20
Thanks: 10
Thanked 9 Times in 8 Posts
Default Timing

OK I have a new question I just built a predator 212 for my non-shifting shifter kart billet rod BP2 cam 26lbs springs* I know I need to put a billet fly wheel that’s next my question is at full throttle I have 54 miles an hour around 5600 RPMs and the motor cuts out doesn’t die just cut out I let off the gas slow down a bit and it picks back up but always around 5600 RPMs does this have to do with not advancing the timing yet flywheels on the way just curious as to what would cause that.
Reply With Quote
  #2  
Old 02-02-2020, 06:57 PM
pearl111 pearl111 is offline
Senior Member
 
Join Date: May 2016
Location: Maryland
Posts: 265
Thanks: 287
Thanked 42 Times in 32 Posts
Default

Did you disconnect the oil sensor wire?
Reply With Quote
  #3  
Old 02-03-2020, 05:21 PM
KartFab's Avatar
KartFab KartFab is offline
Senior Member
 
Join Date: Jan 2013
Location: Dallas, TX
Posts: 3,360
Thanks: 497
Thanked 1,489 Times in 1,050 Posts
Default

valve float, jetting, timing, and gearing all come to mind. Test each one to see.
__________________
Free Go Kart Plans https://kartfab.com Go Kart Videos https://www.youtube.com/c/KartFab
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 01:18 PM.