Go Back   DIY Go Kart Forum > Building Plans And Advice > Engines & Clutches

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 09-28-2019, 04:55 PM
pbneal pbneal is offline
Junior Member
 
Join Date: Sep 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default New member...need help with a parade cart...mini nascar

Good afternoon. I recently purchased a parade cart for use with the Shriners. It looks like a mini nascar cart. So at the first parade we rode in i was having a hard time getting the carb adjusted. It was idling way to high. I could only get it to stay running at about half choke. It was idling fast enough that i had to stand on the brakes to try and keep it from pulling forward. about a third of the way through the parade it was smoking bad. I thought it was the belt. So i pulled off and put it up in the trailer. I figured that the carb needed to be cleaned/replaced. So I am looking for recommendations for that. I took the cover off the clutch to see what shape the belt is in. I found a hand full of brass shards there. I am assuming it is some kind of bushing that is now gone.
This cart has a 7hp Duromax gen II motor.
So here is what I am after:
Recommendations for replacing the carb
not sure if i need a new clutch or if this one can be repaired. Either way some help in figuring that out would be great.
Any further info needed, please ask and I will do my best to answer any questions. I am not very familiar with these things, so like i said I will do my best.

Any and all help will be appreciated.

Click image for larger version

Name:	IMG_1561.jpg
Views:	1
Size:	129.3 KB
ID:	112334

Click image for larger version

Name:	IMG_1562.jpg
Views:	3
Size:	96.9 KB
ID:	112335

Click image for larger version

Name:	IMG_1563.jpg
Views:	2
Size:	111.0 KB
ID:	112336

Click image for larger version

Name:	IMG_1564.jpg
Views:	3
Size:	118.6 KB
ID:	112337

Click image for larger version

Name:	IMG_1565.jpg
Views:	7
Size:	124.5 KB
ID:	112338

Click image for larger version

Name:	IMG_1557.jpg
Views:	1
Size:	122.4 KB
ID:	112339

Click image for larger version

Name:	IMG_1560.jpg
Views:	2
Size:	120.8 KB
ID:	112340
Reply With Quote
  #2  
Old 10-01-2019, 09:56 AM
wenee9w wenee9w is offline
Member
 
Join Date: Aug 2019
Posts: 38
Thanks: 2
Thanked 17 Times in 15 Posts
Default

The brass shards came from the clutch. In between the clutch sheaves. The belt rides on it at idle to keep belt from burning up on the crankshaft shaft. Replace or CLEAN carburetor thoroughly. Your cause of malfunction with the "clutch" or torque convertor in this case was due to the high idle. Oh and replace belt too. Its done.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 06:31 AM.