Go Back   DIY Go Kart Forum > Announcements & Suggestions > Introduce Yourself!

Notices

Closed Thread
 
Thread Tools Display Modes
  #1  
Old 09-23-2018, 04:12 PM
Chopperman Chopperman is offline
Junior Member
 
Join Date: Jul 2018
Posts: 1
Thanks: 1
Thanked 0 Times in 0 Posts
Default Buggy Depot Problems

I am new to this site so please understand I have never posted problems with a company until problems with Buggy Depot.

First of all I ordered an engine in February and did not receive until April. Then all the parts were not shipped, called and some parts were sent but not all of them. Finally after about a month I got all the parts. As I started putting everything together nothing matched up, wrong brackets, wrong cables again another 2-3 weeks and finally got the wrong parts again. Tried getting in touch with Travis but that did not work I guess customer satisfaction is not a priority to him. O' I am sorry he wanted me to send pictures which I had already done about 10 times.

Finally I gave up and started purchasing the right parts on my own. This has probably cost me about another $300.00. Well finally today I got everything together and fired it up and took off. About 50 ft. and the clutch blew into about 100 parts. After further examination the whole clutch assembly was wrong. The shaft was to long so they put a sprocket behind the clutch assembly to use as a spacer. Well the shaft being so long the outer clutch assembly had no room for the spline. I can go on and on but I am so frustrated after spending $1500.00 and still no Buggy
  #2  
Old 09-23-2018, 04:34 PM
Kartorbust's Avatar
Kartorbust Kartorbust is offline
Senior Member
 
Join Date: Feb 2016
Location: Lincoln, NE
Posts: 3,257
Thanks: 670
Thanked 843 Times in 712 Posts
Default

A member on here Joe-405 had a similar issue at the beginning of this year. http://www.diygokarts.com/vb/showthread.php?t=38406
__________________
In the age of information, ignorance is a choice.
The Following User Says Thank You to Kartorbust For This Useful Post:
Chopperman (09-23-2018)
  #3  
Old 09-25-2018, 02:33 AM
landuse's Avatar
landuse landuse is offline
Moderator
 
Join Date: Nov 2010
Location: Pietermaritzburg, South Africa
Posts: 17,963
Thanks: 2,447
Thanked 3,659 Times in 2,992 Posts
Default

Sorry about all the problems man!! That sucks

Welcome to the forum though!!!
  #4  
Old 09-25-2018, 06:44 AM
mckutzy mckutzy is online now
Senior Member
 
Join Date: May 2008
Location: bc, canada
Posts: 7,899
Thanks: 903
Thanked 1,887 Times in 1,561 Posts
Default

Hello and welcome..
Post some pics of this and the drive train, let's see what we can help with..
__________________
10yr+ club..... My current ride- http://www.diygokarts.com/vb/showthread.php?t=5461
  #5  
Old 10-11-2018, 11:11 AM
4EyedTurd 4EyedTurd is offline
Member
 
Join Date: Nov 2008
Posts: 36
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Well crap, I really don’t have fuzzy feelings after placing an order 2 weeks ago and still nothing...
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -6. The time now is 04:21 PM.